You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
49 lines
1.1 KiB
49 lines
1.1 KiB
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
|
|
flake-parts = {
|
|
url = "github:hercules-ci/flake-parts";
|
|
inputs.nixpkgs-lib.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
flake-parts,
|
|
...
|
|
} @ inputs:
|
|
flake-parts.lib.mkFlake {inherit inputs;} {
|
|
systems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
"x86_64-darwin"
|
|
"aarch64-darwin"
|
|
];
|
|
|
|
flake = {
|
|
overlays = rec {
|
|
ablescript = import ./overlay.nix;
|
|
default = ablescript;
|
|
};
|
|
};
|
|
|
|
perSystem = {
|
|
self',
|
|
pkgs,
|
|
...
|
|
}: {
|
|
packages = nixpkgs.lib.filterAttrs (_: nixpkgs.lib.isDerivation) self'.legacyPackages;
|
|
legacyPackages = import ./. {inherit pkgs;};
|
|
devShells.default = import ./shell.nix {inherit pkgs;};
|
|
formatter = pkgs.alejandra;
|
|
};
|
|
};
|
|
|
|
nixConfig = {
|
|
extra-substituters = ["https://ablescript.cachix.org/"];
|
|
extra-trusted-public-keys = ["ablescript.cachix.org-1:ohFVmuceKGwQHeCRRxP8bZeaPX9c+Yl0wU+yHy7NM4M="];
|
|
};
|
|
}
|